127 views 2 comments

DICE Says Next Frostbite Games to Require 64-bit OS

by on May 22, 2012
 

According to Gameranx, DICE, who develops the Battlefield franchise, among others, will require gamers to be using a 64-bit operating system to play upcoming titles currently in development.

Via his Twitter account, Johan Andersson tweets:

“We’ll have Frostbite-powered games in 2013 that will _require_ a 64-bit OS. If you are on 32-bit, great opportunity to upgrade to Windows 8.”

Andersson didn’t specify which games he was referring to but obviously that means they’ve got some hefty requirements for the next title.

DICE recently released the expansion pack for Battlefield in the form of Battlefield 3: Back to Karkand.

comments
 
Leave a reply »

 
  • Avatar of Lukas Jaro
    May 22, 2012 at 1:20 PM

    Mirror’s Edge 2 anyone? :D Still… that’s a bad move. I’m sure they would be able to make these games playable on 32-bit systems as well. They just don’t want to. If they force people to upgrade, Microsoft will have more $$$ not only from 64-bit Win7, but also from 64-bit Windows 8 which people don’t like. They’re rushing things and now they’re afraid no one will want to upgrade so they want to blame it on the software/hardware and make 64-bit OS mandatory. I’m sure many developers will jump on this bandwagon soon. But that’s just a clever marketing excuse. It’s all about the $$$ in the end. Always.

    GD Star Rating
    loading...
    ReplyReport user

Leave a Reply